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About this manual

Typographical 
conventions

This manual distinguishes between different types of
information using the following conventions:

•  Terms taken from the interface itself, such as commands,
appear in bold.

•  Keys appear in small caps, for example: Press the SHIFT

key.

•  Numbered lists indicate that there is a procedure to follow.

•  When the conjunction -or- appears next to a paragraph, it
means there is the option of a different procedure for
carrying out a given task.

•  When a menu command contains submenus, the menu
name, followed by the command to select, appears in bold.
Thus, “Go to File > Open” means go to the File menu, then
the Open command.

This symbol highlights important information on 

how a particular command or procedure works.

Following this symbol, you will find hints and tips
for optimizing tasks, speeding up commands, and
other helpful information.
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Presentation

Welcome!

Label design and integration software provides an easy-
to-use, user-friendly solution for printing bar code labels and
tags to meet compliance standards in any industry.

What is this guide?

This guide provides information to help you understand
how to manage your labeling software in the context of an
enterprise environment.

Who should read this guide?

This Administrator’s Guide is for IT personnel (system
and network administrators) who are responsible for
managing the deployment of software applications,
specifically on the Microsoft Windows platform.
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Product description

Your product includes the following components:

• A CD for the installation

• Complete documentation

• A license agreement and registration card

• A protection key, either electronic (software key) or hard
key (dongle)

System requirements

The configuration required for the software to run properly is
the same as most applications running on Windows:

• One of the 32- or 64-bit Windows® operating system: 7,
XP, Vista, Server 2003, or Server 2008.

• Computer with 1GB of free RAM (depending on the
system).

• A hard drive with at least 500 MB free disk space
(depending on the installation options). 

• CPU: 2 Ghz minimum.

• Video card : DirectX 9 minimum.

• Administrator rights to the computer during the
installation procedure. 

Note

The Release.txt file contains the latest information on 
the software. This information supersedes the 
information contained in this manual.
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Installing

Functional description

The network (multi-user) packages allow you to control
access to the labeling software licenses via the network.
Using this utility, you can have many users accessing the
label design software at the same time, from anywhere on
the network. 
To use the network/multi-user version of your labeling
software, you must install the Network and Users Utilities
on the server or on a station that will serve as a server, then
install the labeling software on each workstation.

Figure 1 Network Configuration Installation: Installation of the 
Network and Users Utilities on the server and installation of 

labeling software on each workstation.

Installation of the Network and User Utilities 

Server

Workstation

Workstation
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Installation procedure

Before you start Before you can install the software, the network
administrator must first define the structure of the network
for the group of users, specifically:

• Define the license server on which the Network and
Users Utilities and the dongle will be installed

• Define the workstations, or the client workstations that
will use the labeling software

Description of 
the Network 
Manager

The Network and Users Utilities let you use the network
configuration of your labeling software. Network Manager
includes:

• The license manager (License Service)

• Network Settings Wizard: The Network Settings
Wizard helps you define the network configuration.

• User Manager: The User Manager is installed with the
Network and Users Utilities so you can define access
rights to the labeling software in a network setting.

Installing the 
Network and 
Users Utilities

Before installing the labeling software on all the workstations
that will use it, you must install the License Service utility on
the server to configure the network.

To install the Network and Users Utilities on the server. 

1 Insert the CD for the installation in the appropriate drive.

The Installation window is displayed.

If the CD-ROM does not run automatically:

2  Go to Start > Run, then type the letter of the CD-ROM
drive, followed by index.hta (for example, D:\index.hta).

3  Select Network and Users Utilities, which includes
License Manager and User Manager. Then click the
Install button.

4  Follow the instructions on the screen



Installing Chapter 2 - 5
6  If you want to define settings for your network
configuration, start the Network Settings Wizard on the
server. By default, if you do not modify the configuration,
each workstation will have its own settings. 

Configuration All the necessary tools to configure the network version are
available from the Network toolbar, accessible by going to
Start > Programs > Teklynx > Network and Users
Utilities and selecting Network Toolbar.

The Network Settings Wizard helps you define the settings
for your network version.

1 To start the Network Settings Wizard, click on the icon.

2  In step 1 of the wizard, select a settings mode: Generic,
By user or By station. 

- Generic: all users will use the same settings on all
workstations. (user.ini)

5  Share the [TKDONGLE] folder with full control, using 
TKDONGLE as the share name. The default access 
path for this folder is C:\Documents and Settings\All 
Users\ApplicationData\Teklynx\LicenseManager\TKDo
ngle(Vista:C:\ProgramData\Teklynx\LicenseManager\
TKDongle) > Right-click > Properties > Sharing tab and 
Permissions button.

For administrators: 

Users wanting Write Access to the Network 
license must be given the rights by: 
1. Sharing the TKDongle folder and authorizing 

the user: C:\Documents and Settings\All 
Users\Application Data\Teklynx\LicenseMan-
ager\TKDongle (Vista: C:\Program Data\Tekl-
ynx\LicenseManager\TKDongle) > Right-click > 
Properties > Sharing tab and Permissions 
button.

2. Give Write Access to the user in the Security 
tab of the TKDongle properties
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- By user: each user can access his or her own settings
on any workstation. (user name.ini)

- By station: each workstation has its own settings 
(station.ini)

3  In step 2, specify the location in which you want to store
these settings. If you want to share these settings between
various workstations, specify a network path accessible to
all workstations. (Example: TKDongle).

4  In step 3, specify the location in which you want to store
the shared data (variables, lists, printing logfile, etc.). Be
sure all users have correct access on these folders.

To configure the User Manager

If you want to define network access rights for all users of
the labeling software, you must do so during installation
(consult the User Manager help system).

•  Click on the User Manager icon , available on the
Network toolbar.

Starting the 
License 
Manager

Before installing the labeling software on all workstations,
you must be sure the license manager is started.

The license manager was installed as Service. You do not
need to start it. In fact, Service starts when the workstation
is turned on and runs as a background task as long as the
workstation is on. 

To start the Service Controller

• Click the icon  available on the Network toolbar
-or- 
Double-click the SLICENSECTRL.EXE file.

If you installed the Service License as software key
protected, you must activate the license before it will
start automatically.
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Installing the 
software on the 
workstations

The labeling software must be installed on all the
workstations on which it will be used.

To install the software on a workstation

1 Insert the CD for the installation in the appropriate drive.

The Installation window is displayed.

If the CD does not run automatically:

2  Go to Start > Run, then type the letter of the CD drive,
followed by INDEX.HTA (for example, D:\index.hta).

3  Select the product to be installed, click the Install button
and follow the instructions on the screen.

4  Start the labeling software. A message is displayed to
inform you that no dongle has been found. Click Yes to start
the software.

5  From the Tools menu, choose Network Administration. 

6  Enable Use Network License. 

7  Click Modify to select the server on which the license
manager and dongle are installed. 
- or -
Click Browse to automatically search for the server on
which the license manager is installed. 

If the network settings has already been configured, a
message asking if you want to use the current network
configuration is displayed. 

8  If you want to modify or configure the network settings,
click the Network Settings Wizard button .

9  Click OK. 

Use the hard Key (Dongle) version of the product.
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10  Restart the program. 

 License protection 

Your software can be protected using a software key (an
electronic code) or a hardware key (a dongle). 

The dongle is a small electronic device that you plug into
your PC’s parallel or USB port before launching the
software. Without the hardware protection key, the program
will run in “evaluation” mode. You will not be able to save
your labels, “e” will be replaced with “x,” “0” with “5” and
images will be crossed when printing.

The software key is an electronic code that is requested by
the Activation Wizard when you launch the software for the
first time or for as long as you have not activated the
software.

You must first run your software installation and then
activate or connect the protection key to your computer.

Hardware Key 
protection

The protection key must be installed on the computer on
which the license manager is installed. A single protection
key, pre-programmed with the number of licenses
purchased, is included with the network version of your
software.

The dongle must be installed before the License Manager
can be started.

If you have purchased a software with a dongle, you can
choose between a USB or parallel port dongle.

If the server is changed, you will have to update all
of the workstations. In this case, start the labeling
software and choose Tools > Network
Administration. Disable and re-enable the Use
Network License option.
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Connecting the parallel key

Figure 2 Connecting the dongle to the parallel port of your PC

Connecting the USB key

Figure 3 Connecting the dongle to the USB port of your PC

When you use a USB key and have multiple USB ports, it
does not matter which port you use. If you do not have an
available USB port, you can use a USB expander hub. USB
devices are hot-swappable, meaning you can plug and
unplug them into the bus any time, without restarting the PC.

Note

Drivers can be installed while the application is running. 
However you must restart your labeling software for the 
changes to take effect.

If you need to use a printer on the same parallel
port, simply plug it into the software protection key.
In this case, it may be necessary to switch the
printer on in order for the software protection key
to be recognized.

 

USB Port

Key
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Error messages 
when launching 
the software

If you are prompted an error message when launching the
software, please check the following items:

• Administrative rights. You must have local administrative
rights on your PC for the key installation to work
properly. If you do not have them, you will see an error
message when launching the software. You will have to
manually install the drivers.

• Driver installation. If you had trouble during installation or
if you are prompted an error message when launching
the software, you will have to install manually the drivers.

• The key. If you receive an error message when launching
the software, check that the connected key works with
your software.

• Driver update. If you receive an error message when
launching the software, your driver may not be updated.
To update your driver, download it from 
http://www.aladdin.com/support/hasp/enduser.aspx

Installing the 
driver key 
manually 

If you want to install your key driver manually, do the
following:

•  Click Start, then click Run. 

•  Enter C:\Program Files\Teklynx\Network\Tools\Dongle\,
then type the following command: \HaspDinst.exe -i 

It is recommended that you close your labeling software
and other applications before installing your driver.

Software key 
protection 

Once you have installed the labeling software, the
Activation Wizard will be launched, taking you step-by-
step through the software key protection process. 

To Activate the software key

1 In the Activation wizard, select Activate, then click Next.

There are three possible activation methods: Online
activation, Activation from another computer and
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Offline activation.

2  Depending on the selected activation method, follow the
appropriate steps to complete the activation process.

Online activation

1 Select Activate online.

Some enterprise networks are protected by a proxy server.
In this case, there is an extra step which allows you to enter
the IP address and connect to the Internet

2  Input your information in the User Registration form.
Click on Next.

3  Enter the Serial number and the password provided with
the product and click on Next.

4  Click on Finish.

Activate from another computer

1 Select Activate from another computer.

2  Enter the Serial number and the password provided with
the product and click on Next.

3  Select the media to use for activation (USB key or external
hard disk…) and click on Next. Files for activation will be
copied into the selected media.

4  Unplug the media.

5  Plug this media into another computer connected to the
Internet.

6  Execute USBWizard.exe (it can be found on the root of
the media). This will start the wizard.

7  Select the license(s) to activate and click on Next.

8  Input your information in the User Registration form.
Click on Next.
A message will inform you that the activation information for
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the selected license(s) has been successfully retrieved

9  Unplug the media from this computer.

10  Plug this media on the computer where the software is
installed and execute USBWizard.exe again (it can be
found on the root of the media).

11  The wizard will display the license that can be activated
on the computer where the software is installed.

12  Click on Next.

13  Click on Finish.

If any problems were encountered, a message will inform
you that the activation has failed and an error will be
displayed.

Activate offline

1 Select Activate offline.

2  Select one of the three possible offline activation
procedures: Activate by email, Reset a pending email
activation (allows you to get a new Serial number and
Password in case of problems), Activate by phone.

    Email activation

3  Input your information in the User Registration form.
Click on Next.

4  Enter the Serial number and the Password provided
with the software and click on Next. 

5  Send the email created to activations@teklynx.com.

6  Click on Exit to launch the software in trial mode.

7  When you receive the Validation code and the
Installation code, please start the software to launch the
wizard.

8  Select Continue a pending activation and click on
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Next.

9  Enter the Validation code and the Installation code
returned by email and click on Next.

10  Click on Finish.

Reset a pending email activation

This activation mode can be used if you have not sent the
email for activation or if you have lost your license. A new
Serial number and Password will be delivered to enable you
to proceed with the activation process.

Activate by phone

3 Call the contact displayed in the wizard depending on
your location.

4 You will be required to provide a User Registration via
the phone. Please have your company information at
hand as well as the Serial number, Password and
User Code.

5 Enter the Validation code and the Installation code
provided by phone and click on Next.

6 Click on Finish. 
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Network Use

Managing users

License 
Service 
Controler

The license manager is installed as a service. This service,
referred to as SLicense, is enabled automatically when the
server is turned on.

The License Service Controler module, named
SLicenseCtrl.exe, is used to control how the service
functions and to change the standard behavior of the license
manager. You can, for example:

• Start or stop the service

• Display the list of users connected to the labeling
software

Description of the License Service Controler window

•  To start License Service Controler, click on the icon
available on the Network toolbar.

Once started and the window is enabled, the Service
Control window is displayed as follows:
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Figure 1 Main Service Control window

The License Service Controler window displays the list of
users. This list permanently displays the login name of those
currently using the labeling software.

Toolbar

Indicator panel

Frame reserved for
status or error 
messages.

List of users
connected to the 
labelling software.
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The toolbar

The Indicator Panel

The Indicator Panel displays the current status of the
service.

Button Function

Stops the service.

Starts the service.

Refreshes the display: the list of users may not
be updated in certain cases, such as if a
workstation crashes (to reset, press
CTRL+ALT+DEL).

Accesses the Service Control settings dialog
box. This button is only available when the
service is stopped.

Displays the About dialog box. This dialog box
displays the version number of the program.

Indicator = Red: The
service is stopped.

Indicator = Orange:
The service is starting
up.

Indicator = Green: The
service is enabled.
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The Settings dialog box

To access the Settings dialog box

•  Click on .

The Settings dialog box is displayed.

Figure 2 The Settings dialog box

To change the settings

If SLicense.exe was not installed in the [DONGLE] folder, you
must specify the access path to the license file.

1 Enter the new access path to the license file, or click the
Browse button.

2  If you want to allow the service to be stopped while users
are still logged on, check the Enable stopping while users
are connected option.

3  If you want to change the display language of the License
Service Controler, select the desired language from the
Language list.

4  Click OK in the dialog box to update the changes.
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Changing the behavior of the Service

By default, the Service is started automatically when the
workstation is turned on. However, you can change the
behavior of the service in the Services dialog box in the
Windows Control Panel. Refer to the documentation
supplied by Microsoft.

Changing the service startup type

1 Select SLicense from the list of services.

2  Click Startup.

3  Enable the desired startup type. SLicense is configured
to start automatically by default.

Selecting a user account

1 Select this account in the Log on as field.

2  Type and confirm the Password and click OK in the
Service dialog box.

Maximum 
number of users

In case you installed the License Manager on a Windows®
workstation your network version is limited to a maximum
number of users. This means that a 10-user license allows
you to start 10 sessions of the labeling software
simultaneously. If an eleventh user tries to log on, an error
message is displayed indicating that the maximum number
of users has been reached. He or she must wait until one of
the connected users logs off.

To Increase the simultaneous connections you have to
install the License Manager on a Windows® Server

Troubleshooting

Two types of error messages may be displayed. The table
below lists possible problems and describes the
troubleshooting procedure.
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Managing shared resources

Shared 
document files

A document can only be opened by one user in Read/Write
mode. If the same document is opened by other users, it is
opened in read-only mode. This means that only the first
user can modify and save the document. 

To provide security for the work of the group, the opening
mode for documents can be defined in the Options dialog
box in the Document tab, by checking the Open
documents in read only mode by default option.

Message Solution

Protection key
not found

- The key is not connected.

- The dongle is connected to the wrong
port (serial port, for example).

- A printer is connected to the dongle
and is switched off.

- The product has not been activated.

License
Manager
cannot create
the license file

The license file could not be created in
the [TKDongle] folder. This may mean
that a user on the station on which
License Manager was started does not
have the access rights required to write
to this folder. The network administrator
must assign the required access rights
(read, write, delete, and modify, if
applicable).

Note: The document can be printed from read-
only mode.
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Shared data The Network Settings Wizard is used to configure data
sharing for variables, lists of values, and the printing logfile.

To share data, you must specify a path and folder on the
network in step 3 of the wizard.

Shared printing 
logfile

If you selected the generic settings mode in the 
Network Settings Wizard, the printing logfile (which is very
useful for tracking all print jobs) can be configured in the
Printing Logfile dialog box. 

To share the printing logfile with all workstations, you must
first generate the log on one of the workstations.

To generate a printing logfile

1 Go to Tools > Printing Logfile.

2  Enter the access path to the folder in which shared data
is saved and a file name for the Printing Logfile, then select
a text editor.

3  Enable your options in the Options tab. For more
information on the Printing Logfile, refer to the Online Help
system.

Note

As with shared variables, if multiple users are working 
on the same file, only one Printing Logfile is created and 
it tracks all print jobs for each user. However, a user can 
generate a personal file.

Shared file 
timeout period

When a shared file, such as a file of shared variables, is
opened by a user, it cannot be accessed by other users who
must wait until it becomes available before editing it. After a
timeout period (defined by you), a message is displayed
asking the user if he or she wants to continue waiting or
cancel the request.

To define the timeout period

1 Go to Tools > Options.

2  Click the Others tab.
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3  Type a value in the Shared files access timeout period
(ms) text field.

Printing A flashing colored indicator indicates the status of the
current print job in the Print Status dialog box. This status is
only displayed if you display the print dialog box in the
labeling software.

• Green: The data is being printed.

• Orange: A user is currently using a shared resource
(printer or variable).

• Red: Error.

To display the print dialog box

1 Go to Tools > Options and click the Printing tab.

2  Disable the Hide the Cancel Print dialog box option. 



Network Use Chapter 3 - 21
Notes for the network administrator

This section describes folders on the server and
workstations, and the required access rights.

Folders on the server
During installation, the [TKDONGLE] folder is created. It is
important for each user to have Read/Write access to the
shared TKDONGLE folder. 

Folders on the workstation

The table below describes each of the sub-folders of the
[COMMON] folder and the required access rights. The access
path to this folder is C:\Documents and Settings\All
Users\Application Data\Teklynx\ 
(Vista: C:\Program Data\Teklynx\ )

R=Read W=Write M=Modify C=Create

Note

Users must be given, at minimum, Read/Write access to 
all available folders in the default folders list (Tools > 
Options... > Default folders).

Folder Rights

[COMMON APP PATH]

TEKLYNX\[PRODUCT NAME]

RWMC

[COMMON APP PATH]\
TEKLYNX\LICENSEMANAGER

RWMC
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