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About this manual

Complete documentation is provided to help you make
optimum use of the full range of resources offered by your
software.

The online help  provides instant access to context-sensitive
help.

The Administrator’s Guide covers the basic concepts to
ensure you to get the very most from the software. It is
designed to provide effective help for administrators, both
first-time and experienced users.

The User’s Guide  provides an introduction to using the
application. It is designed to get you off to a quick start
with the software by familiarizing you with the basic
concepts before looking at some of the more advanced
functions. 

The documentation is designed for use in conjunction with
the integrated online help.

The purpose of this guide is to get you off to a quick start
with the software by familiarizing you with the basic
concepts before looking at some of the more advanced
functions performed by the application administrator.  

The Administrator’s Guide contains four sections covering:

• Installation procedures
• Basic principles and description of modules
• Overview of the User Manager



• Overview of the Web Manager
• Overview of Sentinel Manager
• Overview of Sentinel Controller

The guide describes the most straightforward way of
carrying out specific tasks. For more detail on the different
functions, step-by-step procedures and reference
information, refer to the online help.

This manual distinguishes between different types of
information using the following conventions:

• Terms taken from the interface itself, such as commands,
appear in bold.

• Keys appear in small caps, for example: ”Press the SHIFT

key”.
• Numbered lists mean there is a procedure to follow.
• When the conjunction -or- appears next to a paragraph,

it means there is the choice of another procedure for
carrying out a given task.

• When a menu command contains submenus, the menu
name followed by the command to select appear in bold.
Thus, ”Go to File > Open” means choose the File menu
then the Open command.

This symbol highlights important information on 

how a particular command or procedure works.

Following this symbol you will find hints and tips
for optimizing tasks, speeding up commands, and
so on.
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Module Description

This chapter covers the following topics:

• The Application Modules
• Web Manager
• User Manager
• The Kernel
• Sentinel Manager
• Sentinel Controller
• Mapper
• Query Manager
• Plug-ins
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The application modules can be cassigied into 3 categories
depending on their usage in the software.  

The first category comprises of the kernel module, the
controller,  Sentinel Manager, the user manager and the
Web Manager application.   All of them are used to create,
configure and run SENTINEL processes.  They all come
with SENTINEL’s server installation.

The second category comes included with the workstation
installation.  It comprises of two applications: The Mapper
and the Query Manager.  Both are used to preset the
configuration files for the defined sentinels by the server. 

The third category is the Plug-in modules.  Plug-ins are
thin application modules dedicated to accomplish one
unique task.  They performe all the actions a sentinel is
configured to do.  They are installed by the both the server
and designer installations.  

The application modules

Web Manager The Web Manager acts as an interface to the SENTINEL
Server over the internet/intranet.  It allows the user to
interact with any SENTINEL Server, regardless of its
location, via their internet browser by typing in the web
application’s address in the browser’s address line. 

User Manager The User Manager secures the internet connections to the
SENTINEL server, by allowing an administrator to set
permissions for application users. 

Kernel Kernel is the core application that manages all other tasks,
including launching sentinels and monitoring sentinel
activity. If Kernel is closed, all sentinels will be disabled. 

Kernel operates as a background task and can be
configured to launch automatically when your workstation is
started up. It is therefore not necessary to open a Windows
work session for the application to run. 

Once launched from the application program group, the
Kernel module appears as an icon on the Windows taskbar.
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You can access Sentinel Manager and Sentinel Controller
via the Kernel menu.

Step 1 Right-click on the Kernel icon .

Step 2 Choose the required module in the menu.

Sentinel 
Manager

Sentinel Manager is launched via the Kernel menu and
allows you to create, configure and manage the sentinels
that will analyze your datafiles.

Sentinel 
Controller

Sentinel Controller is launched via the Kernel menu or
Sentinel Manager. It allows you to view sentinel status,
enable or disable individual sentinels and display the error
logfiles. 

Mapper Mapper allows you to create and configure the mapfiles
which will analyze your datafiles. A mapfile describes the
structure of the datafiles for analysis and assigns the
mapped data to the corresponding variables in the initial
document. Mapper is accessed via the application program
group or Sentinel Manager. 

Mapper features an integrated wizard to guide you through
the process of creating and configuring mapfiles.  See the
User’s Guide for a full description of the module and
examples of how to create mapfiles.

Query Manager This application module lets you define queries over
different database systems and lets you group them into
tasks that can later be invoked by a sentinel through the use
of the database process plug-in.

Plug-ins Plug-ins are independant modules dedicated to perform a
very specialized task for a sentinel.  Plug-ins are controlled
and activated by the kernel module.  Four types of plug-ins
are availables:

- Input plug-ins
- Process plug-ins
- Report plug-ins
- Output plug-ins
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Discovering the Mapper

This chapter covers the following topics:

• How Mapper Works

• Launching the Mapper

• Description of the main window
• Menu bar
• The toolbar
• The Tree
• The workspace
• The wizard
• The Status bar
• Online help
• Keyboard Shortcuts
• Changing Display Options

• Changing the work environment
• Customizing the control variables
• Defining the test set
• Converting the workfile
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How Mapper works 

Before creating sentinels with Sentinel Manager, you must
first define the structure of the datafiles to be analyzed by
the sentinels. This is done by using the Mapper. 

Mapper features an integrated wizard to guide you through
the process of creating and configuring mapfiles. 

Launching the Mapper 

You can launch the Mapper by going to Start > Programs
> Sentinel > Mapper or by clicking on the Mapper icon in
your Sentinel Manager.

 Figure 1. Mapper icon

Description of the main window

This section presents a general overview of the interface
elements as they appear in the main window at the
beginning of a worksession. The main window is divided into
three areas:

• The tree
• The workspace
• The map creation wizard

Figure 3  The Mapper 

Menu Bar The menu bar comprises of six drop-down menus: File,
Structure, Block, Zone, Options and Help. Select the
function by clicking on the appropriate menu and sub-menu
item.  Alternatively, you can use the keyboard shortcuts by
pressing ALT and the key corresponding to the letter
undelined in the menu (or sub-menu) item. 

Example:

To access the Save function using the keyboard shortcuts,
you would press ALT and ‘F’ key simultaneously, followed
by ALT and the ‘S’ key. 
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The Toolbar These tools allow you to execute routine tasks more quickly
than by using the menus. To select a tool, click on the button
corresponding to the tool.

 Figure 2  The Mapper  toolbar

The Tree. The tree describes the structure of the file as you define it
and includes additional information such as the target
process used to ease the linkage between the Mapped data
and the variables published by the process plug-ins

Figure 3  The Tree

The workspace
The tree

The map creation wizard
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The Workspace The workspace is used to display the workfile and to define
its structure. This involves selecting the data zones that you
wish to retrieve from the datafiles constructed using the
displayed datafile as a model. The color coding enables you
to distinguish clearly between the different types of
elements.

The Wizard The wizard panel, located in the lower part of the window, is
a step-by-step guide to help you through the process of
creating mapfiles. 

The wizard launches automatically when you create a new
map and overrides the application menu commands to
ensure you follow the instructions in the correct order.

The wizard panel is made up of two sections: the left-hand
pane describes the procedure and the actions to be taken,
providing you with detailed information and examples along

Initial 
document 
filename

Example header or 
start of zone search 
methods 
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the way; the right-hand pane is the input area. Use the right-
hand pane to enter the different settings necessary to create
your mapfile. Once the map is completed, you can close the
wizard panel by going to Options > Show help panel
command. Leaving it open, on the other hand, will give you
instant access to the information you need.

The Status bar Located along the lower edge of the window, the Status bar
displays the cursor position within the block, the character
code selected with the cursor, and the number of characters
selected. 

Figure 4  The status bar

Online Help The online help provides reference information and
explanations on procedures. To access the online help, go
to Help > Contents....

Keyboard 
Shortcuts

Keyboard shortcuts are a quicker way to carry out routine
keystrokes. For a full list of keyboard shortcuts, please see
the diagram at the end of this manual. 

                           
Changing 
Display Options

You can customize your interface by changing the language
and modifying the color settings, font attributes and
wordwrap settings used for displaying you workfile by
selecting Options from the menu bar.  

You can change the color settings used for each type of
element in the workfile (header, footer, blocks, zones, etc.),
to enable you to distinguish them with greater ease.  

  
  

 
 

LocationNumber of selected 
characters

character
code

Cursor position
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Example: 

Figure 5 The Color settings dialog box

Step 1 Choose Options > Display Colors...

Step 2 Assign a new color to each element as 
required.

A preview of the color selected can be see in the Sample
text box, just below the color palette. 

Step 3 Click on OK.

Changing the work environment

You can assign a number of different names to each control
variable. You can also define a test set to validate the map.

Customizing the 
control 
variables

Control variables allow you to define how a process plug-in
is going to act in regards to the data found in each datafile
block.  Control variables of the label printing plug-in  let you
define, for example , the label to be printed, the printer on
which to print it, the quantity to print.  The database plug-in
only gets one control variable (@TASK) which lets you
specify the task to be executed. Only one control variable is
also given to the web service process plug-in which can
dynamically select the function of the web service to call
through its @WEBMETHOD control variable.  

You can use control variable names to assign control
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variables to data. In certain cases, particularly when working
with polyzones, you must use an alias.

Step 1 Choose File > Customize control variables. 
The Customization dialog box appears.

Step 2 Enter the names to be added to the control 
variables in the Other names column.

Step 3 Click on OK.

For more information on control variables, refer to the help
topic entitled The Control variable customization dialog box
in the Mapper online help.

Note

Depending on the product version you have 
installed, some control variables may not be 
available.

Defining the test 
set

A test set allows you to run a compliance test on a series of
datafiles to ensure the mapfile structure is correct. The test
results are displayed in a grid.

Figure 7 The Test set definition dialog box

Step 1 Choose File > Define test set…  The Test set 
definition dialog box appears. 

Step 2 Check the File set option if you wish to run 
tests on files other than the workfile.

Step 3 Enter the access path to the folder containing 
the files on which you wish to run the test.
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- or –

Click on the browse button and select the folder.

Step 4 Enter all or part of the filename in the Files 
named box. If you wish to run the test on a number of 
files or wish to refine your search, use an asterisk * to 
replace the name, a question mark ? to replace a char-
acter, or simply enter the file extension of the files to be 
tested (e.g. *.TXT).

Step 5 Click on List to display the list of files to be 
tested.

Step 6 Click on OK

Step 7 Go to File > Test to run the test and display the 
results

Converting the 
workfile

Mapper allows you to convert tabs into spaces, convert the
OEM (ASCII) character set into ANSI to make the workfile
easier to read.

You can also use the Decode file option to convert a datafile
coded in UTF-7, UTF-8, Unicode or Reversed Unicode into
a standard Windows text file or the XSF to text file option to
convert an XSF file generated using SAP, which is difficult
to read, into a simple text file.                                                                                                                                    

Figure 8 The File conversions dialog box

Step 1 Go to File > Convert....
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Step 2 Check the required option and insert the cor-
rect number of spaces – where applicable.

Step 3 Click on Apply to display the result on your 
workspace then click on OK



C H A P T E R  3

Discovering Mapfiles

This chapter covers the following topics: 

• What is a mapfile
• Header
• Block
• Zone
• Footer

• Workfile types
• ASCII Tables
• Form-type structures
• Unformatted/Raw data structures
• Assignment & Table-type Structures

• Direct assignment
• Table assignment



Chapter 3 - 16 User Guide

What is a mapfile ?

Mapfiles are created using the Mapper.  They are used to
define datafile structures so that the information in the
datafile can be interpreted  and processed by the sentinels. 

Once created, the map is assigned to one or more sentinels
in Sentinel Manager, which uses it as a template for
analyzing similar files generated by your system. 

Regardless of the type of datafile to be analyzed, Mapper
provides a straightforward means of organizing the data you
wish to retrieve into a hierarchical structure.

Your datafile structure may include a header, footer and any
number of blocks. Blocks may be composed of zones,
which, in turn, may be substructures of the main structure.
The mapfile allows you to define each of these elements
with its respective break and search method.

Figure 1  Example datafile structure

Header 
(optional) 

The header is an information zone located at the beginning
of the structure. It is excluded from datafile analysis simply
by specifying where it ends.

Blocks Blocks are structured in the same way as the data they
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contain. Each block contains a number of data zones used
for label printing.

Blocks are used to describe the repetitive sections of the
datafile, such as table rows or form pages.

Zones Each zone contains a data item to be extracted and has a
corresponding search method defining its start and end.
Mapper will help you locate these zones in each of the
blocks at the same level in the hierarchy.

Footer 
(optional)

The file footer is an information zone located at the end of
the structure. It is excluded from data analysis. It is defined
simply by indicating where it starts.

The first step in defining the structure involves choosing the
template for organizing the data that will be used. The
definitions and examples of each type of structure listed
below will help you choose the right template.

Workfile types

ASCII table ASCII table files contain data organized in table format.
Each row in the table represents a record. 

The wizard will automatically suggest settings for this type of
file.

The application supports two ASCII table formats:

File footers are searched from the bottom up of 

the structure
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Figure 2 Example of a character-delimited ASCII table

• Character-delimited. Data items are separated by
commas, semi-colons, or other characters.

• Aligned in columns. The separator is a non-printable
character such as a space or tabulation.

 

Figure 3  Example of an ASCII table aligned in columns

Form-type 
structure

Form-type structures are composed of data organized into
multiple rows. In other words, each record contains a
number of rows. 

With this type of file you must select the different data zones
you wish to retrieve from the datafile one by one
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Figure 4 Example of a form-type file

Unformatted/
raw data 
structure 

Unformatted files contain characters that are not organized
into any type of page setup. They are difficult to read and are
generally used for automated data processing only.

With this type of file you must select the different data zones
you wish to retrieve from the datafile one by one.

 

Figure 5  Example of an unformatted/raw data file

Assignment and 
table-type 
structure

Assignment and table-type files contain data organized by
direct assignment and/or table assignment. With this type of
file, only the syntax of the assignments appearing in the file
needs to be defined in the Mapper.
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Figure 6 Assignment and Tables files

•  Direct assignment 
syntax

Each line describing a variable for analysis must begin with
a start of assignment delimiter, followed by the variable
name, the assignment operator, then the variable value. It
must end with an end of assignment delimiter.

 

•  Table assignment 
syntax

A table assignment datafile groups variables into a table
containing two elements:

• A header specifying the variable associated with

Var1 = Value

Assignment Operator
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each column in the table. The header must be enclosed
by a start of table header delimiter and an end of table
header delimiter.

• A set of values associated with the header variables,
enclosed by a start of table delimiter and an end of table
delimiter.

Data processing will take place for each row of the table.

The variables listed will either be control variables of a
process plug-in or variables involved for data processing.

The advantage to this type of structure is that it can provide
dynamic analysis for a sentinel.  For example, with such a
configuration, the same sentinel is able to analyze files that
can be have differences between them as they could define
labels with a different number of variables and with different
names.

Figure 7  Example of an assignment and table-type structure

Mapper features map and zone creation wizards to guide
you through the entire structure definition process. 
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The map creation wizard launches automatically when you
select File > New to create a new map. It will take you step-
by-step through the process of creating your mapfile,
displaying instructions and hints to help you during each
step.

The zone creation wizard will guide you through the process
of creating zones and automatically suggests the best
method for locating the zones containing the data to be
extracted.

XML XML is a specification of the World Wide Web Consortium
for creating web documents.  It provides a flexible way to
exchange information between applications and systems as
it allows the simultaneous transfer of data and information
structure .  It is now widespread in very different situations
from Electronic Data Interchange (EDI) to web service
method calls over the internet/intranet.

XML documents are text documents but they are displayed
in the Mapper as a hierarchical structure organized into
nodes and sub-nodes with attributes.  Blocks of data must
be defined by simply indicating the node on which
processing should occur.  Zones to be set up for the block
must then be defined one by one. 
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Creating a Mapfile

This chapter covers the following topics: 

• Creating a mapfile: Basic Techniques
• The initial document
• Creating a mapfile

• Modifying a block
• Creating zones

• Creating a simple or structured zone
• Duplicating a zone
• Renaming a zone
• Renaming a structure
• Creating a polyzone
• Creating an action

• Search methods
• Printing the settings
• Modifying the settings

• Creating a mapfile: Advanced Techniques
• Factors specific to assignment and table files

• Defining the settings
• Creating a substructure

• Creating a zone containing a substructure
• Zone sorting
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Creating a mapfile – Basic Technique

Creating a mapfile is easy if you follow the mapping wizard’s
instructions!  First, you must locate the datafile you will be
using (this will be called your workfile).  Then, you must
define your file’s structure type and categorize the file into
blocks and zones.  To finish, you must link the zone in your
workfile to the variables published by the process plug-ins.  

Target 
Processes

Target Process configuration helps you link mapped data
with the variables retrieved by the process plug-ins available
with your product.

Label: The label which will be used to print the mapfile’s
data.  To select a label, double-click on label entry and
browse for the appropriate .lab file. If you own a designer
version of this software, you can also create  a new label or
modify an existing label  by launching your labelling software
from Mapper: Click on  label entry (to make it bold), go to
Structure > Create (or) Modify initial document. 

DB task: The task which will be performed by the sentinel
on the workfile.  To select, double-click on the db task entry

For examples on how to create maps please
see Appendix A, at the end of this manual

This information does not apply once the 
sentinels are running as configuration pri-
ority is first given to coded variables in the 
file (@TASK or @PRINTER) then to the 
plug-in setting in the Sentinel Manager, 
and lastly, to the setting in the Mapper’s 
target processes.

Depending on your version of the product,
this feature may not be available.  Launch
the designer apart from the Mapper to
create your label if this is the case.
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and check the check box corresponding to the chosen task.
(Tasks are created, modified or deleted using the Query
Manager.  See Chapter 5 for more information).

Web Method:The web service function  which will call the
mapfile’s data.  To select, double-click on the Web Method
entry and choose the desired function.  If the listbox is empty
click on Add to browse for a web service and select the
method to be used by the Web Service plug-in (see
Administrator’s Guide for more details about configuring the
Web Service plug-in)  

Creating a 
mapfile

Step 1 Launch Mapper from your Start > Programs 
menu or by right-clicking the Kernel icon , available 

in your window’s taskbar  

Step 2 Go to File > New or click on  to create a 
new mapfile.

The creation wizard launches automatically.

Step 3 Enter the name and access path of the workfile 
you will be using or click on the browse button to 
search for it. 

Step 4 Select a conversion or formatting type accord-
ing to you workfile:

• File conversions
• Wordwrap
• Display font

To preview the data with the label, task or 
web method applied to it, ensure that the 
initial document of choice has been 
selected (it will appear bolded) go to 
Structure > Preview or click on the Pre-
view icon.

While using the creation wizard, most of the 
menu commands will be disabled. Only 

those linked to interface options will remain 

active.
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Click on  to configure the settings

Step 5 Enter a mapfile name and its location. By 
default, the file is saved in the application Maps folder.

Step 6 Select a Structure type.

Step 7 Your next steps will depend on the structure 
type you have selected.

Step 8 If necessary, define a header and footer and 
configure the appropriate settings by clicking on 

.

Step 9 Select the initial document
 
Step 10 Click on Done and Finish

•  Modifying a block Defining a block simply involves specifying where it ends. In
principle, the first block begins immediately after the file
header and ends at the break you set. If the workfile
contains more than one block, this break marks the
beginning of the next block. If the workfile contains only one
block, it marks the end of the file.

Step 1 Select the block in the tree then right-click to 
display the context menu.

Step 2 Click on Define....
The Block definition dialog box appears and suggests
various search methods.

When defining your block, the Process 

option is checked by default as it is the 
block break which launches data process-

ing. The Keep Data allows you to specify 

whether the variable values will be in the 
next block the next label if the correspond-

ing zones are missing.
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Step 3 Select the most appropriate search method for 
locating the break.

Step 4 Once the search method is selected, enter the 
data that characterizes the break then click on OK.

You have now defined the main structure for your workfile.
The tree displays the different elements that make up the
structure and their associated search methods. You must
now define the zones containing the data to be extracted. 

•  Creating Zones There are three types of zones:

• zone
• polyzone
• action

A zone defines the position of the data to be extracted.

 Creating a simple or structured zone

Step 1 Select the data in the workfile using the cursor.

You can modify virtually all elements in the
structure including the file header, footer
and zones

DATE: Dec 17 2000
ORDERNUMBER: 45TI26

Date

Order 
Number
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Step 2 Go to Zone > New zone. 
- or -
Right-click and choose New zone in the context menu.
- or - 

Click on  

The zone creation wizard appears in the lower part of the
window.

Step 3 Enter a name for the zone or select the name of 
the variable in  the initial document to which it will be 
assigned.

Step 4 The wizard will suggest a search method for 
the zone which you can modify if it does not corre-
spond to the zone you wish to create.

The next steps allow you to format the data.

Step 5 Under Zone content, select Simple data or 
Structured data. 

Step 6 Click on Finish.

The new zone appears in the tree with its name, start and
end of zone search methods, and formatting. The
corresponding data is underlined in the workfile.

Duplicating a zone

Step 1 Select the zone in the tree.

Step 2 Choose Duplicate in the context menu.
The new zone appears in the tree followed by “copy no. x”.

When the name of the zone you wish to duplicate ends with
a number, the new zone will end with the same number plus
one. For example, Address1 becomes Address2, Row017

Simple Data refers to a single piece of
data. Ex: a date, a name…. Structured
Data refers to an area that can be sub-
divided into simple data zones.
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becomes Row018, and so on.

When the zone you wish to duplicate uses the String
occurrences search method, the new zone will use the
same search method with the number of occurrences plus
one. For example, 3 x {CRLF} becomes 4 x {CRLF}, and so
on.

Renaming a zone

Step 1 Select the zone in the tree.

Step 2 Choose Rename in the context menu.

Step 3 Enter a new name in the box.

Renaming a structure

Step 1 Go to Structure > Rename 
- or- 
Choose Rename in the context menu.

Step 2 Enter a new name in the box.

Creating a Polyzone

A polyzone is a zone that may appear a number of times
within the same data block. While a zone is associated with
a variable defined once, in a datafile, during map creation, a
polyzone contains information specifying the name of the
variable and the corresponding data which are not specified
until file analysis begins.

A polyzone is defined by the following elements:

• A start of assignment delimiter
• An assignment operator
• An end of assignment delimiter.

When you duplicate a zone containing a 

substructure, the entire substructure is also 
duplicated.
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An action is a zone that launches a process such as
selecting a new document or printer or assigning a value to
the variable selected. 

Step 1 Select the data in the workfile using the cursor.

Step 2 Go to Zone > New polyzone.
- or - 
Right-click and choose New polyzone in the context 
menu.
- or- 

Click on   

The zone creation wizard appears in the lower part of the
window.

Step 3 Enter a name for the polyzone.

Step 4 The wizard will suggest a search method and 
assignment symbol for the zone.

Step 5 Apply any necessary formatting.

LET FIRSTNAME = “Dave”
LET NAME = “Aberdeen”
LET ADDRESS = “1 Palace Street”
LET CITY = “Portland”

Label Variable Data

CALL RESET( )
CALL FEED( )
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The new polyzone appears in the tree with its name, start
and end of zone search methods, assignment symbol, and
formatting. All sections of the block corresponding to these
criteria are underlined.

Creating an action

Step 1 Select the data in the workfile using the cursor.

Step 2 Go to Zone > New action.
- or -
Right-click and choose New action in the context 
menu.
- or -

Click on  

 
Figure 1  The Action definition dialog box

Step 3 Select an action from the list.

Step 4 Complete the action settings.

Step 5 If necessary, check the Prioritize* option then 
click on OK.

The new action appears in the tree with its name, start of
zone, type of action, and settings.

Using a non-prioritized action to assign an existing value
may produce a default value if the zone is not found.

•  Search Methods Search methods are used to delimit the start and end of a
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file, block or zone.

The table below lists the different search methods and their
functions.

•  Printing the 
settings

You can print the settings made. The printout will list all
settings in the structure you have just defined.

Go to File > Print the map settings...

•  Modifying the 
settings

You can modify elements in the structure you have defined
directly from the tree.

Creating and 
modifying an 
target 
document

You can launch your labeling software directly from Mapper
to create or update your initial document. Mapper then
initializes the list of variables, their lengths and current
values. All that remains is to place these variables in your
label as text, barcodes or graphics. For more information on
creating labels, refer to the documentation that came with

If the same result is obtained by another 
zone, the Prioritize option specifies which 
one will be applied.

Search method  How to use 

No search To disable the search for a given element. 

Fixed position The element starts or finishes after n 
characters. 

Character string The element is located after a fixed text 
string. 

String occurrences The element is located after the nth 
occurrence of a fixed text string. 

Character from set The element starts or finishes with the first 
occurrence of one of the characters from the 
set. 

Character not from set The element starts or finishes with the first 
occurrence of a character not from the set. 

The zone follows 
immediately after 
another one. 

The element is located immediately after 
another zone. 

Cascading strings The element is located immediately after a 
fixed text string, which is itself located 
immediately after another fixed text string. 
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your labeling software.

Remember to save the initial document in your labeling
software before returning to Mapper.

The Create a document command is only available if no
initial document (.lab) was selected during the map creation
process. 

The Create a document and Update the 

document commands in the Structure 
menu are only visible if a Designer version 

of your labeling software is installed on your 

workstation.

To preview the label to be printed ex: the 
initial document:

Go to Structure > Preview 
-or– 

click on 
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 Creating a mapfile: advanced techniques

Factors specific 
to assignment 
and table files

Creating a map using an assignment and table file involves
defining a number of specific ASCII sentinel settings from
the previous version of the application.

•  Defining the 
settings

Step 1 Create the structure using the wizard.

A message will appear, informing you that you must define
settings in a separate dialog box.

Step 2 Go to Structure > Specific properties.

The Assignment & table properties dialog box appears.

Step 3 Complete the boxes according to the character-
istics of your datafiles.

Creating a 
substructure

A substructure is simply a structure contained within the
main structure and includes data organized in table form or
as a list. This data, while included in the same datafile, is
used for printing another document. Substructures are
treated in exactly the same way as main structures. They
are used chiefly in form-type files.

•  Creating a zone 
containing a 
substructure

Step 1 Select the part of the zone that will make up the 
substructure.

Step 2 Repeat the above procedure for creating a 
zone until the selection of zone content step.

Step 3 Check Substructure as zone content.

This will take you back to the map creation process. You
must now define the header, footer, initial document, and so
on, of the substructure.

The new substructure appears in the tree and has the
default name Structure. To return to the main structure,
choose Structure Up one level or click on  .

Zone sorting Zone sorting is particularly important for files containing
substructures as the different elements are searched for
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and/or processed in the order they appear in the tree, i.e.: 

• Analysis of the first zone in the main structure, includ-
ing its substructures
• Full analysis and substructure(s) data processing 
• Analysis of next zone(s) in the main structure
• Processing of the main structure.

Step 1 Go to Block > Zone sorting

Step 2 Select the zone to be moved.

Step 3 Use the  buttons to move it up and 
down in the list.

Step 4 Repeat the above operation until all zones are 
in the correct order.

Step 5 Click on OK. 

You can also use the CTRL   (up arrow) and CTRL 
(down arrow) keyboard shortcuts to move zones within the
tree.

If you need to reuse values from a main
zone in a substructure it contains, the main
zone must appear before the substructures
in the tree. If, on the other hand, you wish
to use zones to define printing settings
(printer name, document name, etc.), you
must place them after the substructure so
that it will not modify their content.
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Query Manager

This chapter covers the following topics:

• Using the Query Manager

• About the tables
• Creating new table
• Searching for a record
• Applying the filter

• About the queries
• Creating a new query

• About the tasks
• Creating a new task

• About the Stored Procedures

• Setting an alias
• Defining an alias

• Setting a fixed value
• Defining a fixed value
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The Query Manager is an add-on feature of the SENTINEL
Server that lets you define queries and tasks, create new
tables and view stored procedures over your database
system.  These can be grouped together into tasks that can
be executed via the Database process plug-in.  

Using the Query Manager

Note

 You require an additional license for the Database plug-
inin order to use it in conjunction with this module.  
Please contact your reseller to activate this 
functionality and ensure your database system is 
supported.
  

The possibilities on what can be achieved with the 
Query Manager are endless.  The following steps will 
take you through one example of what can be done:

Step 1 Launch Query Manager by going to Start > 
Programs > Sentinel 5 >Query Manager

Step 2 Define a Datasource.  Go to File > New Data-
source.  A list of possible database system providers 
is shown.  Select the one that best corresponds to your 
database.  

Step 3  Depending on the provider chosen, at this 
step, you will be selecting a Server Name from the 
drop-down menu and/or a Database Name. Click on 
Refresh.

Step 4 Test the connection and click OK

Depending on the provider selected, a different config-
uration may be required from that which is listed 
above.

Step 5 Enter a name for the new datasource

Expanding the datasource will show  any Tables, Queries
and Stored Procedures belonging to the database.  New
tables and queries can be created using the Query
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Manager, however, Stored Procedures cannot.

Once a datasource has been created, tables and queries
must be defined in order to retrieve information and populate
the defined table and database. 

About the tables

Once you have defined a Datasource from the list available
and a database, any tables already present in the database
will be displayed.  If they are not, expand the list of Tables
by double-clicking on Tables or on the x to the left of the list.

Double-clicking on a chosen table will display its contents in
the right-hand window.  Click on  to view the structure
of the table detailing each field, the type of parameter, the
paramenter length... 

The structure can be changed by the user.   Click on 
to view the data in the table.

The toolbar displayed above the table data can be used to
search a specific record in a table or to define a filter so that
only information matching the filter is displayed.

Creating a new 
table

Step 1 Create a table by right-clicking on Tables and 
selecting New...  

Step 2 Click on  to show the table structure.

Select Search Field

Enter Field Value Select All

Deselect All

Apply filter

Cancel Filter
Case Sensitive
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Step 3 Enter all the fields you would like to add, their 
character type, length....Scale refers to the number of 
placeholders following a decimal  (entering 2 = 1,00).

Example: 

You can populate your fields manually by clicking on 
and entering the data corresponding to each field.

Searching for a 
record

Step 1 Select a field from the Select Search Field 
drop-down menu

Step 2 Enter the information you wish to find in the 
Enter Field Value field

Step 3 To make the search case sensitive, leave the 

button un-clicked.  Having the  button in the 
clicked-down position will make the search NOT case 
sensitive (the button will have a lighter color appear-
ance).  

The first matching record will be highlighted in the list. View
the next matching records, one-by-one, by pressing the
ENTER key on your keyboard.

Table:  test_table example

Name Type Length Scale Allow 
Nul

Unique

Nom VarChar 200 Yes No

Prénom VarChar 200 Yes No

Adresse VarChar 200 Yes No

Ville VarChar 200 Yes No

Remember to click Apply to save any changes
you have made.
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Applying a filter Step 1 Click on  to apply a filter

A dialog window will pop up

Step 2 Field tab: Select the fields you want to see and 
click on the right-arrow to move it to the right-hand side 
of the window (Ordered fields).  Use the up/down 
arrows to move a field up or down the list

Step 3 Filter tab: Set a condition on your filter by chos-
ing one or more fields, selecting an operator, search-
ing by specific values and setting a logical operator to 
narrow down a search using as many search criteria 
as you’d like.

Step 4 SQL Query tab: Use this option to manually 
write the filter’s SQL statement by clicking the Modify 
the query in SQL Language check box. 

About the queries

Queries allow the automatic inserting, updating or deletion
of records, of data received by the sentinel’s input plug-in,
into a pre-defined table.

 Creating a new 
query

Step 1  Right-click on Query and select New...  

There are 3 types of query: Insert - to insert data into a pre-
defined table, Update - to update or modify data into a pre-
defined table and Delete - to delete data into a pre-defined
table.

Step 2 Go to Query type and select Insert  and select 
the table you want the information to go into from the 
into table drop-down list

A query table is displayed showing:

Name: field name as in the associated table
Type: field’s character type
Variable: any name entered here will serve as an alias 
to the field name
Value:any data entered here will populate this field in 
all instances
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Step 3 Select the fields that will be used at the query 
level.  
  

All non-selected fields will be set to NULL value. 

At the bottom, the dit textbox lets you see the SQL query you
are building.  

Step 4 Click on Edit to make any modifications, manu-
ally.  

If you choose to work with Update and Delete queries, you
will have to define a WHERE statement in order to identify
which records to work on. For this, you must:

Step 1 Select a field name 

Step 2 Define a condition by choosing one of the avail-
able operators.  The condition can be done by provid-
ing either a fixed value or a variable.  Once executed, 
the variable will receive a value from the incoming data 
stream, either through the use of a direct assignment 
or through a mapped zone.

About the tasks

A task associates queries and/or stored procedures to each
other in order to perform a set function. At execution, when
data processing is requested, the database plug-in calls the
specified task to add/update/delete records and/or execute
stored procedures onto your database systems.  A task can
be specified via the control variables (@TASK), the
Database Process plug-in settings or using the mapfile’s
target process.  If all three options have been defined,
priority is given to the control variables first, to the plug-in

Like with the Stored Procedures, parame-
ters in Queries can be given an alias by 
inserting an alternate name in the Alias field 
of the query table. An alias given at the 
query level will affect all tasks linked to the 
query.
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configuration second, and to the mapfile last. 

Creating a task Step 1 Right-click on Tasks and select New...  

Step 2 Select a datasource and query or stored pro-
cedure from the drop-down lists in the fields and click 
Apply.  

Add as many datasources, queries or stored procedures as
necessary to a task in order to perform the desired function.

The query or stored procedure chosen will be displayed on
the lower half of the screen.  Here, an alias can be created,
for example, to match the query or stored procedure field
names to the field names in the label by entering a new
name under Alias. Remember to select the field, first, by
clicking in the checkbox and clicking Apply, once finished,
to save your changes.

An SQL Statement can be seen at the bottom of the window
detailing the query as stated.  To change the query settings
manually, click on Edit.  This will block the structure screen
and allow manual modifications to the SQL Statement.

Once the task has been created, the list of variables
associated with it are shown beside the task name.  All the
variables will be able addressed during data processing in
order to execute the task.  These variables will be displayed
in the Mapper if the target process for the task is defined.

About the stored procedures

Double-clicking on Stored Procedures will expand the list
of stored procedures predefined in the database.  New
stored procedures cannot be created by using the Query
Manager.  

Setting an alias Query Manager allows the user to define an alias to replace
a database field.  This feature is useful on sentinels with
multiple process plug-ins. This makes it possible to rename
a query (or stored procedure) parameter so that it matches
the name of an existing label bariable.  Therefore, allowing
a zone (from the mapper) to be connected.  
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Defining an 
alias

Step 1 Double-click on the chosen Query or Stored 
Procedure

Step 2 Insert an alias in the Alias column

Setting a fixed value

A fixed value can be defined for a specified parameter in a
query or stored procedure in order to populate that field with
a fixed value.

For instance, a variable called city with a fixed value New
York will populate every city field in the label (and/or the
database) with the value New York.  

Defining a fixed 
value

Step 1 Double-click on the chosen Query or Stored 
Procedure

Step 2 Insert a value in the Fixed Value column

Adding aliases at the task level affects the 
selected task only.  Assigning aliases at the 

query or stored procedure level affects all 

the tasks connected to that query or stored 
procedures. 

As with aliases, a fixed value defined at the 
task level affects the selected task only.  
Fixed Values assigned at the query or 
stored procedure level will affect all tasks 
linked to that query or stored procedure.
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XML Tutorial

What is XML?

XML (eXtensible Markup Language) is a general purpose
markup language much like HTML.  XML was designed to
describe many different types of data and to facilitate the
sharing of structured text and information across the
internet.  XML supports Unicode, making it possible to
communicate in almost every human language.  It has the
ability to represent various data structures such as records,
lists and trees.  Most importantly, XML is platform-
independent, allowing it to be unaffected by technological
changes.

How is it used? XML is used to describe data.  It provides a software- and
hardware- independent way of sharing data since it is stored
in plain text format which makes it easy to use with different
applications, to expand or upgrade a system, servers,
applications and new browsers.  XML can be used to share
and exchange data as it allows data to be exchanged
between incompatible systems.  All sorts of information can
be exchanged, using XML, including financial information –
even over the internet. 
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The XML Structure 

The Structure The XML structure and syntax is similar to HTML but stricter
in its usage.  All documents must contain at least 1 single
tag pair in order to define a root element.  A tag pair opens
with < > and closes with </ >.  Omitting the closing tag will
cause the document to function erroneously or not at all.
Tags are case-sensitive and must be nested properly for the
XML to work properly.  An XML document is made up of
Elements, Attributes, Text and Comments. 

Data can be stored in child elements or in attributes.

Elements An element is defined by a start and end tag.  The first
element of a document is the root element.  A document
can only have one root element; all other elements are
descendants of the root element. Elements are related to
each other as parents and children.  Elements can have
different content types (element content, mixed content,
simple content, empty content or attributes).  When an
element is empty, it can be noted as <tag/>.  In this case,
the element ends as soon as it started.  It can have an
attribute such as <tag attribute=”value”/>

Attributes An element can have one or more attributes.  They are used
to provide additional information about elements and appear
in the start tag with the form:   name = “value”.  Attributes
cannot contain multiple values nor describe structures.
They are more difficult to manipulate by program code and

XML structure
<ROOT_TAG attribute-name= “attribute-value”>
    <PARENT_TAG>
        <CHILD_TAG>
            <TAG>
              A start tag and an end tag define an element
                <!-- A COMMENT CAN BE PLACED ANYWHERE-->
            </TAG>
        </CHILD_TAG>
    </PARENT_TAG>
</ROOT_TAG>
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are not easily expandable for future changes.  If you are
using DTD (Document Type Definition) to define the legal
elements of your XML document, it is important to note that
attributes will not be easily tested.

Text The free text appearing between a start and end tag, but
outside of any tag, is the value of the element.

Comment Text appearing between <!—and --> is a comment.  It is not
viewable outside its source code view and is used for
reference or other non-critical functions.  
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What is XPath? 

XPath (XML Path Language) is a concise non-XML syntax
for addressing portions of an XML document.  It is used
much like a small query language and provides basic
facilities for the manipulation of strings, numbers and
Booleans. In addition to its use for addressing, XPath can be
used for matching, for example, an element to a pattern.
Sentinel Mapper uses the XPath syntax to map XML data
sources.

XPath:

- Is a syntax for finding information in an XML docu-
ment 
- Is used to navigate through elements and attributes in 
an XML document through path expressions and con-
tains a library of standard functions 
- Is a W3C Standard 

The basic XPath syntax is similar to file system addressing
with a few small differences:

- Path uses slashes (/), also called forward slash, 
instead of backslashes (\)
- The result of a query using XPath returns a set of 
matching items instead of one single item
- Regarding the Sentinel Mapper, depending on its 
context, a map item localized by an XPath will desig-
nate the first match (for zones and Actions), or desig-
nate a set of matches (for Blocs and Polyzones). 
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The Syntax

Expression Description 

element Selects all child elements of the element 
/ Selects from the root element 
// Selects elements in the document from the current element that 

matches the selection no matter where they are  
. Selects the current element 
.. Selects the parent of the current element 

@ Selects attributes 
* Matches any element  
@* Matches any attribute  

@name selects the name attribute of the context element 
text() selects all text element children of the context element 
contains(x,x) function returns true if the first argument string contains the second 

argument string 
starts-with(x,x) function returns true if the first argument string starts with the second 

argument string 

(query) [n] The condition in the square brackets is applied to the result of the 
query set by the round brackets as opposed to the elements of the 
document 

Last() selects the last element in the selection 
name() returns the name of the element 
[n] Selects the nth element only 
[condition] Selects only the elements that match the condition 

Count() Evaluates the number of elements found by the expression 
Id() Selects elements by their ID 
string-length() Evaluates the number of characters of the evaluated argument 

Position() Evaluates the rank of the evaluated argument 
Normalize-space() Strips start and end whitespaces 
Comment() Designates the list of comments found at that level 
(+) (-) (*) (div) 
(mod) 

Numerical operations are supported (add, subtract, multiply, divide, 
modulus 

(=) and (!=) To perform equality tests 
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Sample XML 
Document

<?xml version="1.0" encoding="ISO-8859 -1"?> 
<LIBRARY> 
    <SECTION category ="Adult Fiction "> 
        <BOOK> 
            <TITLE  lang="fr">Et si c'était vrai, Marc Levy</ TITLE > 
            <PRICE>29.99</PRICE> 
        </BOOK> 
        <BOOK> 
            <TITLE  lang="eng">The DaVince Code, Dan Brown</TITLE > 
            <PRICE>19.99</PRICE> 
                <!—This BOOK is on the bestseller list -->  
        </BOOK>  
        <BOOK> 
            <TITLE  lang="eng">Deception Point, Dan Brown</ TITLE > 
            <PRICE>19.99</PRICE> 
        </BOOK>  
    </SECTION> 
    <SECTION category ="Children’s Fiction"> 
        <BOOK> 
            <TITLE  lang="eng">Harry Potter and the order of the phoenix, J.K Rowlings</TITLE > 
            <PRICE>24.99</PRICE> 
        </BOOK> 
        <BOOK> 
            <TITLE  lang="eng">Harry Potter and the half-blood prince, J.K Rowlings</ TITLE > 
            <PRICE>24.99</PRICE> 
         </BOOK>  
         <BOOK> 
            <TITLE  lang="eng">Harry Potter and the Sorcerer’s stone, J.K Rowlings</TITLE > 
            <PRICE>24.99</PRICE> 
        </BOOK> 
        <BOOK> 
            <TITLE  lang="eng"> The New Harry Potter box set, J.K Rowlings</TITLE> 
            <PRICE>111.99</PRICE>  
                <!--Includes BOOK 6- ->  
        </BOOK>  
        <BOOK> 
            <TITLE  lang="fr">Les Fables de Lafontaine</TITLE> 
            <PRICE>9.99</PRICE> 
        </BOOK> 
    </SECTION> 
</LIBRARY>  
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Examples Path Expression
- Explanation
 -Result

LIBRARY
- Select all the child elements of the LIBRARY element
-SECTION, BOOK, PRICE, TITLE, PRICE

/LIBRARY
- Selects the root element ‘LIBRARY’
-LIBRARY

/LIBRARY/*
- Selects all the child elements of the LIBRARY ele-
ment
-SECTION, BOOK, PRICE, TITLE, PRICE

LIBRARY/SECTION
- Selects all SECTION elements that are children of 
LIBRARY
-2 SECTIONS (Adult and Children’s fiction)

//BOOK
- Selects all BOOK elements no matter where they are
-8 BOOKS

LIBRARY//BOOK
- Selects all BOOK elements that are children of 
LIBRARY no matter where they are
-8 BOOKS

//@category
-Selects all attributes that are named category
-2 CATEGORIES (Adult and Children’s Fiction)

//TITLE[@*]
Selects all TITLE elements that have an attribute
-8 TITLES

//BOOK/TITLE | //BOOK/TITLE/PRICE
 -Selects all TITLE and PRICE elements of all BOOK 
elements
-16 entries (8 TITLES and 8 PRICES)
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//TITLE | //PRICE
Selects all the TITLE and PRICE elements in the docu-
ment
-16 entries (8 TITLES and 8 PRICES)

/LIBRARY/SECTION/BOOK/TITLE | //PRICE
Selects all the TITLES elements of the LIBRARY/SEC-
TION/BOOK branch
-16 entries (8 TITLES and 8 PRICES)

//*
 -Selects all elements in the document
 -LIBRARY, SECTION, BOOK, TITLE, PRICE

 /SECTION[1]
 -Selects the first SECTION element
 -”Adult Fiction” SECTION

 /LIBRARY/SECTION[last()]
 -Select the last SECTION  that is the child of  
LIBRARY 
-“Children’s Fiction SECTION

 /SECTION[@category=”Children’s Fiction”]/
BOOK[4]
  -Select the 4rth BOOK  in the Children’s Fiction SEC-
TION
  -The New Harry Potter Boxed set

 //BOOK[@lang]
-Selects all the BOOK elements that have an attribute 
named lang
 -8 of them

 //BOOK [@lang= ‘eng’]
 -Selects all the BOOK elements that have an attribute 
named lang with a value of ‘eng’
 -6 of them

 /SECTION [PRICE>25.00]/BOOK
 -Selects all the BOOK elements of SECTION that 
have a PRICE with a value greater than 25.00
 -2 BOOKS = “Et si c’etait vrai” &”Harry Potter Boxed 
Set”
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 /SECTION[@category=”Adult Fiction”]/
BOOK[PRICE>25.00]
 -Selects all the BOOK elements of SECTION with a 
category attribute matching Adult Fiction who’s PRICE  
has a value greater than 25.00
 -1 BOOK = “Et si c’etait vrai”

 /SECTION/BOOK[4]
 -Selects the 4rth BOOK  of SECTION
 -The New Harry Potter Box Set  

 (/LIBRARY/SECTION/BOOK)[4]
 -Selects the 4th BOOK found by the bracketed query; 
the whole of the document
 -Harry Potter and the Order of the Phoenix

 /LIBRARY/SECTION[count(BOOK)=3]
 -All SECTION elements of  LIBRARY having exactly 3 
child elements named book
 -”Adult Fiction” SECTION

 //*[starts-with (name(), “P”)]
 -Any element at any level that starts with uppercase‘P’
 -PRICE

  //*[contains (name(), “L”)]
 -Any element at any level as long as the name con-
tains the letter Uppercase ‘L’
 -9 elements ... LIBRARY and TITLE

 //*[string-length (name())=4]
 -Any element at any level as long as the name is 4 
characters long
 -8 BOOK 

 //*[position()=2]
 -Any element at any level as long as it is in 2nd rank
PRICES (8)
 -2 comments
 
 /LIBRARY/SECTION/BOOK/comments
-Any comment appearing inside a BOOK element 
(child of SECTION which is child of LIBRARY)
 -1 SECTION, 2 BOOKS and all 
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 // BOOK [PRICE<10.00]/../@category
-Finds the value of the SECTION that is parent to the 
BOOK element with a BOOK whose PRICE is less 
than 10.00
 -“Children’s Fiction

XPATH and the Mapper

Value, Name, 
Position

When a set of items (elements, attributes or comments)
have been selected by a query, you can choose, if you want,
to use the value of the items (test of elements or value of
attributes), the name of the items (mostly useful for
polyzones) or the position of the items.

Example:

The XPath //SECTION[2]/@*[1] selects the first attributes of
the second SECTION element found in the document.

- When “Value” is chosen: result is “Children’s Fiction”
- When “Name” is chosen: result is “category”
- When “Rank” is chosen: result is “1”

Mapping with 
XPath

When an XPath defines a map item, the search is applied to
the item’s container.  i.e. the XPath to locate blocs is based
on its structure and the XPath to locate a zone is based on
its bloc.

Using the Library sample in the Mapper, the LIBRARY
element automatically becomes the ROOT OF ALL XPath.

If the processing is to be applied to each BOOK element, the
XPath syntax to locate blocs can be:

Since variable names starting with a digit 
are not supported by all Process plug-ins, 

when the rank is used to locate the variable 

name of a polyzone, the polyzone name will 
be used as a prefix.  i.e. a polyzone named 

Items will generate variables named 

Items1, Items2, etc…
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-//BOOK
-/SECTION/BOOK
-SECTION/BOOK
-/*/*
-*/*

It CANNOT be:

-LIBRARY/SECTION/BOOK
-/LIBRARY/SECTION/BOOK

If a zone has to locate the lang attribute of the TITLE
element, the XPath syntax can be:

-TITLE/@lang
-TITLE/@* (assuming the lang attribute is always the 
first attribute)

If a zone has to locate the category attribute of the parent
element SECTION, the syntax can be:

-../@category
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A P P E N D I X  B

Workshops

The application includes several folders containing sample
data and maps designed to help you understand the Mapper
and create a mapfile.  Each example illustrates a different
type of structure.

Non-printable 
ASCII 
characters

The workfile may contain characters which do not have a
visual representation. Mapper includes a specific font
enabling you to display the ASCII CR (\010) and LF (\013)
characters as    

Non-printable ASCII characters can be introduced during
the wizard process by entering their names between braces
{ }. For example: {CR}, {CR ESC LF}.

The non-printable ASCII characters are:

NUL SOH STX ETX EOT

ENQ ACK BEL BS HT

LF VT FF CR SO

SI DLE DC1 DC2 DC3

DC4 NAK SYN ETB CAN

EM SUB ESC FS GS

RD US DEL NULL
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    Workshop 1: ASCII table-type structure

This structure is used for extracting data for label printing
from ASCII files. 

 
Figure 1   ASCII table-type datafile

The SILENCO.TXT file is an ASCII table-type file and will
serve as our workfile. It represents one of the possible types
of files generated for label printing.

Step 1 Launch Mapper. 

The main Mapper window appears.

Step 2 Go to File > New....

The map creation wizard will take you step-by-step through
the process of creating your mapfile.

Step 3 In the wizard window, enter or select the 
SILENCO.TXT workfile located in the Sample Maps > 
01 Silenco folder. 

The workfile appears in the workspace.

The  characters displayed in the workspace are the visual
representation of the tab character (ASCII 09). The next
step allows you to convert these tabs into spaces.

.  
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Step 4 In Conversions and formatting, select File 
conversions then click on the Settings button. Select 
Tabs to spaces then enter 8 as the number of spaces. 
Click on Apply to display the result then click on OK.

 Figure 3 The file appears as shown abovebelow.

Step 5  Enter a map filename. If you do not enter a file-
name, Mapper will automatically name it for you.

Step 6  Choose the Table: ASCII delimited or 
aligned structure.

Your workfile may contain a header and/or footer. These
contain no data relative to label printing or value table
headers. The wizard allows you to delimit the header and/or
footer to exclude them from data searches.

 In our example, the header corresponds to the first three
rows. 

Figure 4  Header to exclude from data searches

The following search method used in this
example represents only one of several.
Others would serve equally as well.

Header
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Step 7 Select the Header option then click on the Set-
tings button. 

Step 8 To specify that the header ends at the third row, 
choose String occurrences. In String, enter {CRLF} 
then select 3 in Occurrences.

The file contains no footer to be excluded.

Step 9 In the Table format step, the wizard suggests 
the Aligned in columns format, which it determined 
automatically.

Step 10 Position and Sizing: the Mapper automati-
cally determines the position and size of the columns.  
However, you can manually change the sized by click-
ing in the column and dragging the edge to the left or 
right to include all data listed in the column.

Step 11 Select the SILENCO.LAB label as your initial 
document. The initial document is the label you cre-
ated using your labeling software

 

Figure 5  The SILENCO.LAB Label 

The tree describes the file structure exactly as you have just
defined it. You will now need to link the SILENCO.LAB label
variables with the zones defined in the tree.

Step 10 Right-click on each zone and choose Link to 
a document variable. 

In our example, zones with the same name as the document
variables are linked automatically. Others must be linked
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manually. These include:

• The HF zone corresponding to the HOUR VARIABLE 
• The REF zone corresponding to the REFERENCE 
variable
• The WEIGHT zone corresponding to the WEIGHT 
VARIABLE 
• The TYP zone corresponding to the TYPE VARI-
ABLE 
• The SIZE_MIN_ zone corresponding to the SIZE vari-
ables 
• The PRODUCT_NAME zone corresponding to the 
PRODUCT NAME variable.                   

Figure 5 & 6  The tree as originally defined and The tree linked to 
document variables

Step 11 Click on the   button to display the result 

in a label. 

Step 12 You can also run a compliance test on your 
mapfile by going to File > Test... The results of the test 
will be displayed in a spreadsheet.

The map is now complete and is linked to the sentinels you

Zone whose name corresponds to 
a variable in the initial document

Zone whose name does not 
correspond to a variable in 
the initial document
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created in the Sentinel Manager to analyze files of this
type.

Workshop 2: Form-type structures

Let us suppose you wish to retrieve datafiles generated by
an ERP system to print two labels: EXPE.LAB and
EXPESUB.LAB 

  
Figure 7  The EXPE.LAB label

  
Figure 8 The EXPESUB.LAB label

The EXPEDITION.TXT form-type file will serve as our
workfile. 

Step 1 Launch Mapper.
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Step 2 Go to File > New....

The map creation wizard will take you step-by-step through
the process of creating your mapfile.

Step 3 In the wizard window, enter or select the EXPE-
DITION.TXT workfile located in the Sample Maps > 12  
Expedition  folder.

 

Figure 9 The workfile appears in the workspace.

The  characters displayed in the workspace are the visual
representation of the tab character (ASCII 09). The next
step allows you to convert these tabs into spaces.

 Step 4 In Conversion and formatting, select File 
conversions then click on the Settings button. Check 
Tabs to spaces then enter 4 as the number of spaces.  
Click on Apply to display the result then click on OK.
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Figure 10 The file appears as shown above

Step 5 Enter a map filename. Mapper will automati-
cally assign a mapfile name if you skip this step.

Step 6 Choose the Form structure.

Creating the 
header and 
footer  

Your workfile may contain a header and/or footer. These
contain no data relative to label printing or value table
headers. The wizard allows you to delimit the header and/or
footer in order to exclude them from data searches.

In our example, the header corresponds to the first three
rows up to the row containing the text EXPEDITION SHEET,
which is repeated several times in the file.

Figure 11 Header to exclude from data searches

The following search method used in this
example represents only one of several.
Others would serve equally as well.

End of header

Start of block
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There are a number of search methods allowing you to
define the file header and footer. In our example, we have
chosen to delimit them using a character string.

Step 1 Check the Header option then click on the Set-
tings button. 

Step 2 Choose Character string. In String, enter ---
{CRLF} then select 0 in Offset.

Step 3 Click on Apply to display the result.

You must now define the file footer.  

Figure 12 File footer

Step 4 Check the Footer option then click on the Set-
tings button. 

Step 5 Choose Character string. In String,  enter <---
-- then select 0 in Offset. The search method in a 
footer counts from the bottom-up

Step 6 Click on Apply to display the result.

Block definition In the Composition step, the wizard will ask you whether
your structure contains more than one block. Browsing
through the workfile, you will notice that certain sections
contain data for label printing and that these sections are
repeated several times. In our example, the blocks are
delimited by a row containing the text EXPEDITION SHEET.
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Step 1 Check the The structure contains several 
blocks option then click on the Settings button.

You must now define an end of block. Given the blocks are
delimited by the string EXPEDITION SHEET, the simplest
way to define the end of block is to search for this character
string.

Step 2 Choose Character string. In String, enter 
EXPEDITION SHEET then click on Apply.

You will notice that Mapper has selected part of the line
containing the text EXPEDITION SHEET as a block. What
has happened is that Mapper stopped at the first
occurrence of EXPEDITION SHEET it found. You thus need
to specify that the block ends at the second occurrence of
EXPEDITION SHEET. 

 Step 3 Choose String occurrences. In String, enter 
EXPEDITION SHEET then select 2 in Occurrences.

Step 4 In order for the end of block to start at the 
beginning of the row, enter -49 in Offset then click on 
Apply to display the result.

 

Figure 13 End of Block

Step 5 In the Initial document step, select the 
EXPE.LAB label as the initial document.

You have now completed the first stage in the process of
defining the structure of your mapfile.

The tree describes the file structure exactly as you have just
defined it. You must now define the zones containing the

End of block
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data to be extracted.

 

Figure 14 The tree displays the structure

Creating zones Creating the DATE ZONE

In our example, the first zone to be defined is the one
containing the date. 

 Step 1 Select the data in the workfile using the cursor.

 

Step 2 Click on  to create a new zone.

The zone creation wizard appears in the lower part of the
window. 

Step 3 Enter DATE as the zone name or select it in the 
list of variables.

During the following steps, the wizard will automatically
suggest the search method for this zone and allow you to
format the data.
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Step 4 In the Zone content step, check the Simple 
data option then click on Next to finish the zone cre-
ation procedure.

Creating the ORDER NUMBER ZONE

The second zone to be defined is the one containing the
order number. 

Step 5 Repeat the above procedure for the ORDER 
NUMBER zone and enter ORDER as the zone name 
or select it from the list of variables.

A number of other zones corresponding to label variables
also need to be defined: 

• The SHIPPING TOTAL  zone corresponding to the 
TOTAL VARIABLE 
• The FROM zone corresponding to the FROM VARI-
ABLE 
• The FREIGHTER zone corresponding to the VIA vari-
able 
• The TO zone corresponding to the EXP_TO_NAME, 
EXP_TO_STREET, EXP_TO_CITY and 
EXP_TO_COUNTRY VARIABLES.

Creating the SHIPPING TOTAL ZONE

Step 1 Select the data in the workfile using the cursor.

Step 2 Click on  to create a new zone.

Step 3 In the Name step, select TOTAL from the list of 
variables. 

In the following steps, the wizard will automatically suggest
the search method for this zone and allow you to format the
data.
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Step 4 In the Zone content step, check Simple data 
then click on Next to finish the zone creation proce-
dure.

• Repeat the above operation for the FROM and 
FREIGHTER zones.

Creating multiple zones for the TO field

In your Expe.lab label, the TO field includes the
EXP_TO_NAME and EXP_TO_STREET variables. For the
TO field, you must therefore create a number of zones.

Step 1Select the data in the workfile using the cursor.
 

Step 2 Click on   to create a new zone.

Step 3 In the Name step, select EXP_TO_NAME from 
the list of variables. 

In the following steps, the wizard will automatically suggest
the search method for this zone and allow you to format the
data.

 In this case, we have selected a zone rather than simply an
item of data. It is thus recommended that you delete any
spaces before and after the data.

Step 4 In the Data formatting step, select Delete start/
end spaces then click on  .

Step 5 In the Zone content step, check the Simple 
data option then click on Next to finish the zone cre-
ation procedure.

• Repeat the above operations for the 
EXP_TO_STREET, EXP_TO_CITY and 
EXP_TO_COUNTRY zones.

Creating a 
substructure

All that remains is to define a zone which we will call
DETAILS. This zone is composed of data organized in a
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table format that will be extracted to print the
EXPESUB.LAB label. The table is a substructure of the
main structure and we will treat it in the same way. 

Figure 14 Details Zone

Step 1 Select the entire zone in the workfile using the 
cursor.

Step 2 Click on   to create a new zone.

Step 3 Enter DETAILS as the zone name then check 
the Substructure option in the Zone content step.

Step 4 Next select Table: ASCII delimited or aligned 
as the structure type.

As for the main structure, you must define a header which,
in our example, corresponds to the table header. 

Creating the 
header and 
footer 

Step 1 Check the Header option then click on the Set-
tings button. 

Step 2 Choose String occurrences. In String, enter 
{CRLF} then select 2 in Occurrences.

Step 3 Check the Footer option then click on the Set-
tings button. 

Step 4 Choose String occurrences. In String, enter 
{CRLF} then select 2 in Occurrences. To ensure per-
fect symmetry between the blocks, apply an offset of 2.
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Defining the 
table format

Step 1 In the Table format step, the wizard suggests 
the Aligned in columns format, which it determines 
automatically.

The next step allows you to adjust the columns.

 Figure 15 Aligned in Columns

Step 2 Select the first empty column, and then click on 

 to delete it.

Step 3 Delete the column containing ”g” then widen 
the WEIGHT column to cover the ”g”. 

Step 4 Reduce the width of the NET column to the 
break (kg) then widen the SHIPPING COST column to 
cover the “$” symbol and the beginning of the title.

Step 5 Select the EXPESUB.LAB label as the initial 
document.

 

Delete the column

Increase the column 
width  

Decrease the column width
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Figure 16 The tree tree displays the structure

The tree describes the file structure exactly as you have just
defined it. You now need to link the EXPESUB.LAB label
variables with the zones defined in the tree.

Linking 
document 
variables

Step 1 Right-click on each zone and choose Link to a 
document variable. 

In our example, zones with the same name as the document
variables are linked automatically. Others must be linked
manually. These include:

• The PIECES zone corresponding to the QTY variable
• The NET zone corresponding to the 
TOTAL_WEIGHT VARIABLE.

Step 2 Click on the   to display the result. 

Step 3 To return to the main structure, choose Struc-

ture > Up one level or click on  .

Step 4 Click on the   button to display the result. 

The map is now complete and is linked to the sentinels you
created in Sentinel Manager to analyze files of this type.



Workshops Appendix B - 73

Workshop 3: Assignment and table-type 
structures

DYNAMIC1.TXT is an assignment and table-type file and
will serve as our workfile. This is a type of file generated for
label printing.

Step 1 Launch Mapper.

Step 2 Choose File > New....

The map creation wizard will take you step by step through
the process of creating your mapfile.

Step 3 In the wizard window, enter or select the 
DYNAMIC1.TXT workfile located in the Sample Maps 
> 21 Dynamic folder.

 

Figure 15  The file appears as shown above below

Step 4 No formatting conversions are necessary.

Step 5 Enter a map file name.
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Step 6 Choose the Assignment and table (S2 com-
patible) structure.

Your workfile may contain a header and/or footer. These
contain no data relative to label printing or value table
headers. The wizard allows you to delimit them in order to
exclude them from data searches.

In our example, the header ends after the word SENTINEL 

Figure 16 Header to exclude from data searches

Step 7 Check the Header option then click on the Set-
tings button. 

Step 8 Choose Character string. In String, enter 
SENTINEL then click on Apply to check the result.

The file contains no footer to be excluded. 

The advantage of this type of structure is that it uses the
same sentinel to analyze datafiles generated for printing
different labels.

Step 9 Click on Next then on Finish. 

Figure 17 The tree displays the structure

The following search method used in this
example represents only one of several.
Others would serve equally as well

Header
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Locating the 
data

The tree displays the file structure exactly as you have just
defined it. You must now specify the Delimiters used in the
datafile to locate the data to be extracted.

Step 1 Double-click on Assignment and table in the 
tree. 

Figure 18 The Assignment and table properties dialog box dialog 
box

Step 2 Complete the dialog box as shown above then 
click on OK.

The map is now complete and is linked to the sentinels you
created in Sentinel Manager to analyze files of this type.

The SAMPLE MAPS folder contains further 
mapfile examples.
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Workshop 4: XML structure

A hospital distribute medication to its patients 3 times a day.
The IT system generates an XML file describing each
patient’s prescription.  The pharmacist who controls the
distribution must prepare the dosages for each patient to be
distributed by a nurse.  Each drug must be labeled for
tracking purposes.

This structure is set for extracting data for label printing from
XML files. 

Step 1 Launch Mapper.

The main Mapper window appears

Step 2 Go to File > New...

The Map Creation Wizard will take you through the a step-
by-step process for creating you mapfile.

Step 3 In the wizard window, enter or select the PRE-
SCRIPT.XML workfile located in the Sample Maps > 
xml Hospital folder

The workfile appears in the workspace.

Step 4 Click Next to skip the Conversions and For-
mats wizard window as the XML document has been 
encoded in UTF-8 standard (as shown in the XML 
workfile header.)

Step 5 Name the mapfile and assign it a location.  If 
you do not name the file or location, a default name 
and location will be given to your mapfile.

Step 6 Under Table Structures, select XML and click 
Next.

Since the structure type has not yet been 
determined, the Mapper displays the XML 
file as a text file.
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Once you have selected XML as the structure type, you will
notice that the way the workfile is displayed changes.  It now
resembles a hierarchy.  You will notice that the nodes are
displayed in black lettering, the node attributes are red and
the node text in bolded (black).  You can expand the nodes
to view the available information. 

Step 7 In the Composition Wizard window, select the 
option The structure contains several blocks

Step 8 Click on Patient in your workfile to expand it, 
then click on Part and click the settings button in the 
wizard to set the block.
Step 9 In the XPATH Query field, type Patient/Part to 
set Part  as the block.

An orange dot will appear next to the assigned block.

Step 10 Click Next and Finish.

Creating Zones Creating zones on a workfile allows you to extract data from
the workfile and send it to a label or database.  Before
creating zones, you must select your label.  

Step 1 In the tree view, double click on Label to open 
the browse window.  Select the Prescript.lab file in 
Sample Maps > xml Hospital folder.

Once you’ve clicked OK, you should see the path to your
label displayed in the tree view.

Step 2 To create a zone, a data node must be acti-
vated in the  workfile

Step 3 Double-click on Part to expand it and view the 
data.

Step 4 Click on Product to activate the data. 

Step 5 Click on the New Zone button in your toolbar.

The Zone Wizard opens

Step 6 Select a name for the new zone by clicking on 
the drop-down menu and selecting it from the list.
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Step 7 In the following step, the wizard takes you to 
the XPATH Query displayed as ‘@Product’ .  This 
means that the Product attribute is in the current node 
(the Part Block)

The first zone has been created.  A green dot appears next
to it to show that it is a Zone.  Continue setting the zones for
this workfile until they have all been created (Name, Room,
Form, Posology, Text, ID, Date, Shift, Control). 

Once all the zones have been created, you can click on the
View Label button to verify that the zones have been
properly created  for the selected label.

You will notice, when setting the Name 

zone that Name is not available in the drop 
down list.  This is because although the 

workfile attribute is called Name, the asso-

ciated field in the chosen label is called 
Patient.

When creating zones, notice how the
system sets the XPATH query for zones that
placed before the block.  (...\ means that
the search must go up one level to find the
data or   ..\..\ to go up two levels).  For the
zone Text, the suggested query is Text( )
to indicate that the text must be extracted
from the current Part node.
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